FastX System Requirements

Server

RedHat systems (including CentOS)

Version 6 or later (version 7 is the latest release), 64-bit  only.

SuSE (including OpenSUSE and SLES)

Version 11 or later.

Debian (including Ubuntu)

Debian 7 (“Wheezy”) or later.
Ubuntu 11.10 (“Oneiric”) or later.

 

Notes

Processors

The processor must be from the x86 family (i.e. Intel or AMD). FastX is not supported on ARM.

RAM

The amount of RAM required is dependent on the number of sessions you wish to run.  Please see FastX Memory Usage for more information

NodeJS

NodeJS version 6+ is required for the web component.  The FastX install script will attempt to install it if it is not on your system.

RHEL 5 based Systems

Partial support is available for RHEL 5.8 and later.
Direct SSH client/server connections are supported.
Features requiring a web server (Clustering, load balancing, administrators, browser access etc) are not available.

Desktop Client

  • Windows 7 or later
  • Mac OS 10.8 or later
  • Linux RHEL 6 (or equivalent) 64 bit

Browser Client

  • IE 10+
  • Edge
  • Chrome
  • Firefox
  • Safari